[ 新規に投稿する ]

「エラーコード1が返りました」への対処法No.36070
旧姓山下 さん 17/09/26 12:10 [ コメントを投稿する ]
  こんにちは

マクロを実施し,「エラーコード1が返りました」と出て止まってしまった場合,どの辺りをチェックすればよろしいでしょうか.これは,どのようなときに出るエラーメッセージなのでしょうか.

PCはWindows10,秀丸エディタはv8.75b9(最新のベータ版)です.

マクロは「祝鳥」で,TeX処理→dvipdfmx経由でのPDFファイル作り,としたとき,エラーが出ます.ただし,2,3日前に同じ処理をした際には問題なく終了しています.秀丸エディタ関係,マクロ関係,TeX関係は2,3日前から一切変更していません.

PCには,この2,3日でフォントを幾つかインストールしたり,ソフトを幾つかインストールしたりしております.

現在でも,TeX処理→dvi出力とする場合にはエラーが出ません.

斯様な次第ですから秀丸側の問題ではなく,dvipdfmx付近,あるいはフォント付近のトラブルかとも思うのですが,エラー表示は秀丸エディタから出てきますので,まずはこちらでお尋ねさせていただく次第です.

以上,よろしくお願い致します.

山下

[ ]
RE:36070 「エラーコード1が返りました」への対処法No.36072
秀丸担当 さん 17/09/26 15:09 [ コメントを投稿する ]
 
「エラーコード1が返りました」というエラーメッセージは、秀丸エディタ自身
は出しておらず、マクロが出しているものと思われます。
マクロというより、マクロが実行するTeX関係の何らかのプログラムが返す、プ
ロセスの終了コードなのではないかと思います。
秀丸エディタとしてはわからないです。申し訳ありません。
[ ]
RE:36070 「エラーコード1が返りました」への対処法No.36073
あべのり さん 17/09/26 16:14 [ コメントを投稿する ]
  >マクロは「祝鳥」で,TeX処理→dvipdfmx経由でのPDFファイル作り,としたとき,エラーが出ます.ただし,2,3日前に同じ処理をした際には問題なく終了しています.秀丸エディタ関係,マクロ関係,TeX関係は2,3日前から一切変更していません.

それ自身は祝鳥が出力しているメッセージかと思います.様子からするとdvipdfmxが発しているようです.

メインメニュー→お手伝いさん→ログファイルを開く

とするとdvipdfmxが発しているメッセージが見られますので,そちらを確認してみてください.
[ ]
RE:36072 「エラーコード1が返りました」への対処法No.36077
旧姓山下 さん 17/09/26 20:16 [ コメントを投稿する ]
  秀丸担当様

ご回答ありがとうございました.

>秀丸エディタとしてはわからないです。申し訳ありません。

承知しました.

山下
[ ]
RE:36073 「エラーコード1が返りました」への対処法No.36078
旧姓山下 さん 17/09/26 20:21 [ コメントを投稿する ]
  あべのり様

ご回答ありがとうございます.

>それ自身は祝鳥が出力しているメッセージかと思います.様子からするとdvipdfmxが発しているようです.
>
>メインメニュー→お手伝いさん→ログファイルを開く
>
>とするとdvipdfmxが発しているメッセージが見られますので,そちらを確認してみてください.

申し訳ないことながら,コンパイル用のマクロ(ttex)だけ残し,祝鳥本体はマクロ登録を取り消していると思います(自分でもはっきりしませんが).祝鳥本体のマクロを改めて登録し,ログファイルを見てみたいと思いますので,本体のマクロ名を教えていただけないでしょうか.

以上,よろしくお願い致します.

山下
[ ]
RE:36078 「エラーコード1が返りました」への対処法No.36083
あべのり さん 17/09/27 13:00 [ コメントを投稿する ]
  >申し訳ないことながら,コンパイル用のマクロ(ttex)だけ残し,祝鳥本体はマクロ登録を取り消していると思います(自分でもはっきりしませんが).祝鳥本体のマクロを改めて登録し,ログファイルを見てみたいと思いますので,本体のマクロ名を教えていただけないでしょうか.

fortex.macです.
またはシンプルにコマンドラインから動かしてみてもよいかとは思いますが.
[ ]
RE:36083 「エラーコード1が返りました」への対処法No.36085
旧姓山下 さん 17/09/27 19:45 [ コメントを投稿する ]
  あべのり様

ご回答ありがとうございました.

>fortex.macです.

承知しました.

fortexマクロ設定前にコマンドラインで試してみたところ,原因はパスではなかろうかと推察し,色々と試してみたところ解決しました.

Windows7 では環境変数のPATHにセミコロン「;」区切りで並べますが,Windows10 ではセミコロン区切りではなく,1行ごとに並べるという方式をとらねばならないのですね.

なぜ数日前にうまくいったのかが理解できませんが,とにかく解決しました.ありがとうございました.
[ ]

[ 新規に投稿する ]